]> Pileus Git - ~andy/sunrise/blob - dev-python/venusian/venusian-0.6.ebuild
f9f632255499ba3e7537edeae530e1a911028116
[~andy/sunrise] / dev-python / venusian / venusian-0.6.ebuild
1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=3
6
7 PYTHON_DEPEND="2"
8 SUPPORT_PYTHON_ABIS=1
9 RESTRICT_PYTHON_ABIS="3.*"
10
11 inherit distutils
12
13 DESCRIPTION="A library for deferring decorator actions"
14 HOMEPAGE="http://www.repoze.org"
15 SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
16
17 LICENSE="repoze"
18 SLOT="0"
19 KEYWORDS="~amd64 ~x86"
20 IUSE="doc"
21
22 DEPEND="doc? ( dev-python/sphinx )"
23 RDEPEND=""
24
25 src_test() {
26         testing() {
27                 PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" setup.py "test"
28         }
29         python_execute_function testing
30 }
31
32 src_compile() {
33         distutils_src_compile
34         if use doc ; then
35                 emake -C docs html || die "make html failed"
36         fi
37 }
38
39 src_install() {
40         distutils_src_install
41
42         if use doc ; then
43                 dohtml -r docs/.build/html/* || die "dohtml failed"
44         fi
45 }