]> Pileus Git - ~andy/sunrise/blob - dev-python/ubuntuone-storage-protocol/ubuntuone-storage-protocol-1.2.0.ebuild
07bf79ac08a55c4b77a72dc35f134bfd4a778553
[~andy/sunrise] / dev-python / ubuntuone-storage-protocol / ubuntuone-storage-protocol-1.2.0.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=2
6
7 SUPPORT_PYTHON_ABIS="1"
8 RESTRICT_PYTHON_ABIS="2.4 2.5 3.*"
9 PYTHON_DEPEND="2:2.6"
10
11 inherit distutils python
12
13 DESCRIPTION="Storage protocol for Ubuntu One cloud file hosting"
14 HOMEPAGE="http://launchpad.net/ubuntuone-storage-protocol"
15 SRC_URI="http://launchpad.net/${PN}/trunk/lucid-final/+download/${P}.tar.gz"
16
17 LICENSE="LGPL-3"
18 SLOT="0"
19 KEYWORDS="~x86"
20 IUSE=""
21
22 RDEPEND="
23         dev-libs/protobuf[python]
24         dev-python/pyopenssl
25         dev-python/pyxdg
26         dev-python/twisted
27         dev-python/oauth"