]> Pileus Git - ~andy/sunrise/blob - dev-python/schemabot/schemabot-0.1.0_alpha4.ebuild
add missing die
[~andy/sunrise] / dev-python / schemabot / schemabot-0.1.0_alpha4.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6 SUPPORT_PYTHON_ABIS="1"
7
8 inherit distutils
9
10 MY_PN="SchemaBot"
11 MY_P="${MY_PN}-${PV/_alpha/a}"
12
13 DESCRIPTION="Automatically manage database schema version control when using SQLAlchemy"
14 HOMEPAGE="http://bitbucket.org/chrismiles/schemabot/wiki/Home"
15 SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
16
17 LICENSE="MIT"
18 SLOT="0"
19 KEYWORDS="~amd64"
20 IUSE="test"
21
22 DEPEND="dev-python/setuptools
23         test? ( dev-python/nose )"
24 RDEPEND=""
25 RESTRICT_PYTHON_ABIS="3.*"
26
27 S="${WORKDIR}/${MY_P}"
28
29 src_test() {
30         testing() {
31                 PYTHONPATH="build-${PYTHON_ABI}/lib" LC_ALL="C" nosetests-${PYTHON_ABI}
32         }
33         python_execute_function testing
34 }