]> Pileus Git - ~andy/sunrise/blob - dev-python/pyRXP/pyRXP-9999.ebuild
6fd7a28e41f491fcfd018fec492d60557a8bf9da
[~andy/sunrise] / dev-python / pyRXP / pyRXP-9999.ebuild
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit distutils subversion
6
7 DESCRIPTION="Binding to RXP, a very fast validating XML parser."
8 HOMEPAGE="http://www.reportlab.org/pyrxp.html"
9 ESVN_REPO_URI="http://svn.reportlab.com/svn/public/${PN}/trunk/src"
10
11 LICENSE="as-is"
12 SLOT="0"
13 KEYWORDS=""
14 IUSE="doc examples"
15
16 DOCS="README"
17
18 src_install() {
19         if use doc;then
20            DOCS="${DOCS} docs/*"
21         fi
22
23         distutils_src_install
24
25         if use examples;then
26            docinto examples
27            dodoc examples/* || die "dodoc examples code failed"
28         fi
29 }