]> Pileus Git - ~andy/sunrise/blob - dev-python/flask-debugtoolbar/flask-debugtoolbar-0.5.ebuild
media-libs/oyranos: moved to tree
[~andy/sunrise] / dev-python / flask-debugtoolbar / flask-debugtoolbar-0.5.ebuild
1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="3"
6 PYTHON_DEPEND="2"
7 SUPPORT_PYTHON_ABIS="1"
8 RESTRICT_PYTHON_ABIS="2.4 3.*"
9
10 inherit distutils
11
12 MY_PN="Flask-DebugToolbar"
13 MY_P="${MY_PN}-${PV}"
14
15 DESCRIPTION="A port of the Django debug toolbar to Flask"
16 HOMEPAGE="http://github.com/mvantellingen/flask-debugtoolbar"
17 SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
18
19 LICENSE="BSD"
20 SLOT="0"
21 KEYWORDS="~amd64 ~x86"
22 IUSE="doc examples"
23
24 RDEPEND="dev-python/flask
25         dev-python/flask-sqlalchemy
26         dev-python/simplejson"
27 DEPEND=""
28
29 S="${WORKDIR}/${MY_P}"
30
31 PYTHON_MODNAME="flaskext/debugtoolbar"
32
33 src_install() {
34         distutils_src_install
35
36         if use examples; then
37                 insinto /usr/share/doc/${PF}
38                 doins -r example || die "Installation of examples failed"
39         fi
40 }