]> Pileus Git - ~andy/sunrise/blob - dev-python/django-debug-toolbar/django-debug-toolbar-0.8.5.ebuild
sunrise/ net-nntp/nzbperl/Manifest: Update copyright line to satisfy repoman
[~andy/sunrise] / dev-python / django-debug-toolbar / django-debug-toolbar-0.8.5.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="3"
6 PYTHON_DEPEND="2"
7 SUPPORT_PYTHON_ABIS="1"
8 RESTRICT_PYTHON_ABIS="3.*"
9
10 inherit distutils
11
12 DESCRIPTION="A set of panels that display debug information about the current request/response in django"
13 HOMEPAGE="http://robhudson.github.com/django-debug-toolbar/"
14 SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
15
16 LICENSE="BSD"
17 SLOT="0"
18 KEYWORDS="~amd64 ~x86"
19 IUSE="examples"
20
21 RDEPEND="dev-python/django"
22 DEPEND=""
23
24 src_prepare() {
25         sed -ie "s/'ez_setup'/'ez_setup','example'/" setup.py || die
26 }
27
28 src_install() {
29         distutils_src_install
30
31         if use examples; then
32                 insinto /usr/share/doc/${PF}
33                 doins -r example || die "Installation of examples failed"
34         fi
35 }