]> Pileus Git - ~andy/sunrise/blob - dev-python/concurrence/concurrence-0.3.1.ebuild
c48a42738a9cf8cbf53bfc2eab4879d69ace426c
[~andy/sunrise] / dev-python / concurrence / concurrence-0.3.1.ebuild
1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=3
6 SUPPORT_PYTHON_ABIS=1
7 PYTHON_DEPEND='2:2.5'
8 RESTRICT_PYTHON_ABIS='3.*'
9
10 inherit distutils
11
12 DESCRIPTION="Concurrence is a framework for creating massively concurrent network applications in Python"
13 HOMEPAGE="http://opensource.hyves.org/concurrence"
14 SRC_URI="http://concurrence.googlecode.com/files/${P}.tar.gz"
15
16 LICENSE="BSD-2"
17 KEYWORDS="~amd64 ~x86"
18 SLOT="0"
19 IUSE="doc examples"
20
21 DEPEND="dev-python/pyrex
22         dev-python/setuptools"
23 RDEPEND=""
24
25 DISTUTILS_SRC_TEST=setup.py
26
27 src_install() {
28         distutils_src_install
29
30         if use doc; then
31                 dodoc doc/* || die
32         fi
33
34         if use examples; then
35                 docinto examples
36                 dodoc examples/* || die
37         fi
38 }