]> Pileus Git - ~andy/sunrise/blob - dev-lua/luacrypto/luacrypto-0.3.1_p20120320.ebuild
dev-lua/luacrypto: version bump, new build system upstream, remove old
[~andy/sunrise] / dev-lua / luacrypto / luacrypto-0.3.1_p20120320.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=4
6
7 inherit autotools
8
9 DESCRIPTION="Lua Crypto Library"
10 HOMEPAGE="https://github.com/mkottman/luacrypto.git" # most active fork
11 SRC_URI="mirror://github/hasufell/tinkerbox/${P}.tar.gz"
12
13 LICENSE="MIT"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE=""
17
18 RDEPEND=">=dev-lang/lua-5.1
19         dev-libs/openssl:0"
20 DEPEND="${RDEPEND}
21         dev-util/pkgconfig"
22
23 src_configure() {
24         econf \
25                 --htmldir=/usr/share/doc/${PF}/html
26 }
27
28 src_test() {
29         emake test
30 }