]> Pileus Git - ~andy/sunrise/blob - dev-lua/luacrypto/luacrypto-0.3.0_p20120413.ebuild
331428e13d123cd07a1a6bbb2fc9e06c553f3364
[~andy/sunrise] / dev-lua / luacrypto / luacrypto-0.3.0_p20120413.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=4
6
7 inherit eutils multilib toolchain-funcs
8
9 DESCRIPTION="Lua Crypto Library"
10 HOMEPAGE="https://github.com/LuaDist/luacrypto"
11 SRC_URI="https://github.com/downloads/hasufell/tinkerbox/${P}.tar.gz"
12
13 LICENSE="MIT"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="doc"
17
18 RDEPEND=">=dev-lang/lua-5.1
19         dev-libs/openssl:0"
20 DEPEND="${RDEPEND}
21         dev-util/pkgconfig"
22
23 pkg_setup() {
24         tc-export CC
25 }
26
27 src_prepare() {
28         epatch "${FILESDIR}"/20120413-makefile.patch
29 }
30
31 src_install() {
32         if use doc; then
33                 dodoc README
34                 dohtml -r doc/*
35         fi
36
37         emake \
38                 DESTDIR="${D}" \
39                 PREFIX="/usr" \
40                 LIBDIR=$(get_libdir) \
41                 install
42 }
43
44 pkg_postinst() {
45         elog "Note that upstream names the library \"crypto.so\"."
46         elog "and not \"libluacrypto.so\"."
47 }