]> Pileus Git - ~andy/sunrise/blob - dev-libs/xml-core/xml-core-0.13_p2.ebuild
move to appropriate category
[~andy/sunrise] / dev-libs / xml-core / xml-core-0.13_p2.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="5"
6
7 inherit versionator sgml-catalog
8
9 MY_PV=$(replace_version_separator 2 '+')
10 MY_PV=${MY_PV/p/nmu}
11
12 DESCRIPTION="XML infrastructure and XML catalog file support"
13 HOMEPAGE="http://packages.debian.org/xml-core"
14 SRC_URI="mirror://debian/pool/main/x/${PN}/${PN}_${MY_PV}.tar.gz"
15
16 LICENSE="GPL-2+"
17 SLOT="0"
18 KEYWORDS="~amd64 ~x86"
19 IUSE="examples"
20
21 DEPEND="dev-lang/perl"
22 RDEPEND="app-text/sgml-base
23         dev-util/debhelper
24         virtual/perl-File-Spec
25         virtual/perl-Getopt-Long
26         ${DEPEND}"
27
28 S="${WORKDIR}/${PN}-${MY_PV}"
29
30 sgml-catalog_cat_include "/etc/sgml/${P}.cat" \
31         "/usr/share/sgml/dtd/xml-core/catalog"
32
33 src_compile() {
34         emake prefix="${D}"/usr
35 }
36
37 src_install() {
38         emake prefix="${D}"/usr install
39         insinto /usr/share/sgml/dtd/${PN}
40         doins schemas/{catalog,catalog.dtd}
41         insinto /usr/share/xml/schema/${PN}
42         doins schemas/catalog.xml
43         keepdir /var/lib/${PN}
44         insinto /usr/share/lintian/overrides
45         doins debian/lintian-overrides/xml-core
46         dodoc debian/{README.Debian,TODO,changelog}
47         if use examples; then
48                 insinto /usr/share/doc/${PF}
49                 doins -r examples
50         fi
51 }