]> Pileus Git - ~andy/sunrise/blob - dev-libs/qextserialport/qextserialport-1.1.ebuild
dev-libs/qextserialport: Fix qt deps
[~andy/sunrise] / dev-libs / qextserialport / qextserialport-1.1.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="3"
6 inherit qt4-r2
7
8 DESCRIPTION="cross-platform serial port class"
9 HOMEPAGE="http://code.google.com/p/qextserialport/"
10 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
11
12 LICENSE="public-domain"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE="doc examples"
16
17 RDEPEND="dev-libs/qtcore:4"
18 DEPEND="${RDEPEND}"
19
20 PATCHES=(
21         "${FILESDIR}/${P}-install.patch"
22 )
23
24 S=${WORKDIR}/${PN}
25
26 src_install() {
27         qt4-r2_src_install
28         dolib build/libqextserialport* || die
29         if use doc ; then
30                 dohtml html/* || die
31         fi
32         if use examples ; then
33                 insinto /usr/share/doc/${PF}/examples
34                 doins -r examples/* || die
35         fi
36 }