]> Pileus Git - ~andy/sunrise/blob - dev-libs/libserial/libserial-0.6.0_rc1.ebuild
dev-libs/liblouis: Add ~amd64 keyword, EAPI bump
[~andy/sunrise] / dev-libs / libserial / libserial-0.6.0_rc1.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit versionator
6
7 MY_P=$(delete_version_separator "_" ${P})
8
9 DESCRIPTION="A collection of C++ classes which allow serial port access on POSIX systems like an iostream object"
10 HOMEPAGE="http://sourceforge.net/projects/libserial/"
11 SRC_URI="http://dev.gentooexperimental.org/~idl0r/distfiles/${MY_P}.tar.bz2"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="doc examples"
17
18 RDEPEND=""
19 DEPEND="dev-python/sip"
20
21 S="${WORKDIR}/${MY_P}"
22
23 src_install() {
24         emake DESTDIR="${D}" install || die "Install failed"
25
26         doman doc/man/man3/*.3 || die "Install man pages failed!"
27
28         if use doc; then
29                 dohtml -r doc/html/* || die "Install html pages failed!"
30         fi
31
32         if use examples; then
33                 docinto examples
34                 dodoc examples/{read,write}_port.cpp || die "dodoc failed";
35         fi
36 }