]> Pileus Git - ~andy/sunrise/blob - dev-libs/libserial/libserial-0.6.0_rc1-r1.ebuild
dev-libs/liblouis: Add ~amd64 keyword, EAPI bump
[~andy/sunrise] / dev-libs / libserial / libserial-0.6.0_rc1-r1.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="5"
6
7 inherit versionator
8
9 MY_P=$(delete_version_separator "_" ${P})
10
11 DESCRIPTION="A collection of C++ classes which allow serial port access on POSIX systems like an iostream object"
12 HOMEPAGE="http://sourceforge.net/projects/libserial/"
13 SRC_URI="http://dev.gentooexperimental.org/~idl0r/distfiles/${MY_P}.tar.bz2"
14
15 LICENSE="GPL-2"
16 SLOT="0"
17 KEYWORDS="~amd64 ~x86"
18 IUSE="doc examples"
19
20 RDEPEND=""
21 DEPEND="dev-python/sip"
22
23 S="${WORKDIR}/${MY_P}"
24
25 src_install() {
26         emake DESTDIR="${D}" install || die "Install failed"
27
28         doman doc/man/man3/*.3 || die "Install man pages failed!"
29
30         if use doc; then
31                 dohtml -r doc/html/* || die "Install html pages failed!"
32         fi
33
34         if use examples; then
35                 docinto examples
36                 dodoc examples/{read,write}_port.cpp || die "dodoc failed";
37         fi
38 }