]> Pileus Git - ~andy/sunrise/blob - dev-libs/libdbf/libdbf-0.0.1.ebuild
d91fbb1df3f90096e123165ffa72f31855403fe4
[~andy/sunrise] / dev-libs / libdbf / libdbf-0.0.1.ebuild
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 DESCRIPTION="Library to read the content of dBASE III, IV, and 5.0 files"
6 HOMEPAGE="http://developer.berlios.de/projects/dbf/"
7 SRC_URI="mirror://berlios/dbf/${P}.src.zip"
8
9 LICENSE="LGPL-2"
10 SLOT="0"
11 KEYWORDS="~amd64 ~x86"
12 IUSE="doc"
13
14 RDEPEND=""
15 DEPEND="${RDEPEND}
16         app-arch/unzip
17         dev-perl/XML-Parser
18         doc? ( app-text/docbook-sgml-utils )
19         dev-util/pkgconfig"
20
21 S=${WORKDIR}/${PN}
22
23 src_compile() {
24         chmod u+x configure
25         if use doc; then
26                 export DOC_TO_MAN=docbook2man
27         fi
28         econf
29         emake || die "emake failed"
30 }
31
32 src_install() {
33         chmod u+x install-sh
34         emake DESTDIR="${D}" install || die "make install failed"
35 }