]> Pileus Git - ~andy/sunrise/blob - dev-lang/awib/awib-1.0_rc5_beta.ebuild
sunrise/ app-portage/elog-list/elog-list-0.0.6.ebuild: Update headers for 2010
[~andy/sunrise] / dev-lang / awib / awib-1.0_rc5_beta.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit  toolchain-funcs
6
7 DESCRIPTION="Optimizing brainfuck compiler written in brainfuck for Linux on i386."
8 HOMEPAGE="http://www.nada.kth.se/~matslina/awib/"
9 SRC_URI="http://www.helch.ch/gentoo/distfiles/${P}.tar.gz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE=""
15
16 DEPEND=""
17 RDEPEND=""
18
19 src_compile() {
20         $(tc-getCC) ${CFLAGS} -o awib awib.c || die "awib compile failed!"
21         $(tc-getCC) ${CFLAGS} -o wib wib.c || die "wib compile failed!"
22 }
23
24 src_install() {
25         dobin awib wib
26         dodoc awib.b wib.b
27 }