]> Pileus Git - ~andy/sunrise/blob - dev-dotnet/f-sharp/f-sharp-2.0.0.0.2010.11.ebuild
Add a package move entry for pidgin-botsentry (removed in r11593).
[~andy/sunrise] / dev-dotnet / f-sharp / f-sharp-2.0.0.0.2010.11.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=2
6
7 inherit eutils mono versionator
8
9 DESCRIPTION="The F# programming language and tools"
10 HOMEPAGE="http://fsharp.net/"
11 # November CTP
12 SRC_URI="http://download.microsoft.com/download/4/5/B/45BD9FBC-22BA-4B45-84B7-17D1AD0122A1/fsharp.zip -> ${P}.zip"
13
14 LICENSE="MSR-SSLA"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17 IUSE=""
18
19 RDEPEND=">=dev-lang/mono-2.6"
20 DEPEND="app-arch/unzip
21                 ${RDEPEND}"
22
23 S=${WORKDIR}/FSharp-$(get_version_component_range 1-4)
24
25 create_exe_wrappers() {
26         ebegin "creating compiler wrappers"
27
28         for exe in fsi fsc; do
29                 make_wrapper ${exe} "mono /usr/$(get_libdir)/${PN}/${exe}.exe" \
30                         || die "couldn't create wrapper for ${exe}.exe"
31         done
32
33         eend $?
34 }
35
36 src_install() {
37         insinto "/usr/$(get_libdir)/${PN}"
38         doins bin/* || die "installing libraries failed"
39
40         local libname=bin/FSharp.Core.dll
41
42         # Sign $libname with the Mono key, per the instructions
43         # in install-mono.sh.
44         sn -q -R "${S}/${libname}" "${FILESDIR}/mono.snk" \
45                 || die "couldn't sign the ${libname} assembly"
46
47         # After signing, this should work.
48         egacinstall "${libname}" \
49                 || die "couldn't install ${libname} in the global assembly cache"
50
51         create_exe_wrappers
52 }