]> Pileus Git - ~andy/sunrise/blob - dev-db/sql2class/sql2class-1.9.2-r1.ebuild
dev-db/sql2class: Add ~amd64 keyword, EAPI bump
[~andy/sunrise] / dev-db / sql2class / sql2class-1.9.2-r1.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="5"
6
7 inherit eutils toolchain-funcs
8
9 KEYWORDS="~amd64 ~x86"
10
11 DESCRIPTION="SQL C++ code generator (to use with dev-db/*wrapped packages)"
12 HOMEPAGE="http://www.alhem.net/project/sql2class/index.html"
13 SRC_URI="http://www.alhem.net/project/sql2class/${P}.tar.gz"
14 LICENSE="GPL-2"
15 SLOT="0"
16 IUSE="mysql sqlite"
17
18 DEPEND=""
19 RDEPEND=""
20
21 src_prepare() {
22         sed -i \
23                 -e 's/\(CPPFLAGS\) =/\1+=/' \
24                 -e 's/-Wall -O2 -g//' \
25                 -e 's#/usr/devel#/usr#' \
26                 -e 's/g++/$(CXX)/' \
27                 Makefile || die "sed failed"
28 }
29
30 src_compile() {
31         emake CXX="$(tc-getCXX)" || die "emake failed"
32 }
33
34 src_install() {
35         dobin sql2class
36         dodoc README
37 }
38
39 pkg_postinst() {
40         elog "You might want to emerge one of the following packages as well:"
41         elog "-> dev-db/mysqlwrapped ... to use the generated code with a MySQL-DB"
42         elog "-> dev-db/sqlitewrapped ... to use the generated code with SQLite"
43 }