]> Pileus Git - ~andy/sunrise/blob - dev-db/dabo/dabo-0.9.2.ebuild
d3e4a0d38f1b4571cf46a38ef0be6d68e028a385
[~andy/sunrise] / dev-db / dabo / dabo-0.9.2.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=3
6
7 inherit distutils multilib
8
9 DESCRIPTION="A 3-tier, cross-platform application development framework written in Python/wxPython"
10 HOMEPAGE="http://dabodev.com/"
11 SRC_URI="http://cdn.cloudfiles.mosso.com/c118811/${PN}/${P}-mac-nix.tar.gz"
12
13 LICENSE="MIT"
14 SLOT="0"
15 KEYWORDS="~x86"
16 IUSE="ide"
17
18 DEPEND=">=dev-python/setuptools-0.6_alpha9"
19
20 RDEPEND=">=dev-python/wxpython-2.6.1.1
21         >=dev-db/sqlite-3.0
22         >=dev-python/pysqlite-2.0
23         ide? ( dev-python/imaging dev-python/reportlab )"
24
25 S=${WORKDIR}/${PN}
26
27 src_install() {
28         distutils_python_version
29         ${python} setup.py install --root="${D}" --no-compile \
30                 --single-version-externally-managed "$@" \
31                 --install-data="/usr/$(get_libdir)/python${PYVER}/site-packages/" \
32                 || die "setup.py install failed"
33
34         dodoc ANNOUNCE AUTHORS ChangeLog README TODO || die
35
36         if use ide; then
37                 cd "${S}/ide"
38                 INS="/usr/$(get_libdir)/python${PYVER}/site-packages/${PN}/ide"
39
40                 insinto ${INS}
41                 doins -r * || die "IDE installation failed!"
42
43                 # pick out those files which should be executable
44                 for EFIL in $(grep -RI '^#!' * | cut -d : -f 1 | grep -iv '\.txt$')
45                 do
46                         # and if there are any - install them
47                         exeinto "${INS}/$(dirname ${EFIL})"
48                         doexe "${EFIL}" || die
49                 done
50         fi
51 }