]> Pileus Git - ~andy/sunrise/blob - dev-db/dabo/dabo-0.9.2-r1.ebuild
dev-db/dabo: Add ~amd64 keyword, EAPI bump
[~andy/sunrise] / dev-db / dabo / dabo-0.9.2-r1.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="5"
6
7 inherit distutils multilib
8
9 DESCRIPTION="A 3-tier, cross-platform application development framework written in Python/wxPython"
10 HOMEPAGE="http://dabodev.com/"
11 SRC_URI="http://cdn.cloudfiles.mosso.com/c118811/${PN}/${P}-mac-nix.tar.gz"
12
13 LICENSE="MIT"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="ide"
17
18 DEPEND=">=dev-python/setuptools-0.6_alpha9"
19
20 RDEPEND=">=dev-python/wxpython-2.6.1.1
21         >=dev-db/sqlite-3.0
22         dev-lang/python[sqlite]
23         ide? ( dev-python/imaging dev-python/reportlab )"
24
25 S=${WORKDIR}/${PN}
26
27 src_install() {
28         distutils_src_install
29
30         dodoc ANNOUNCE AUTHORS ChangeLog README TODO || die
31
32         if use ide; then
33                 cd "${S}/ide"
34                 INS="/usr/$(get_libdir)/python${PYVER}/site-packages/${PN}/ide"
35
36                 insinto ${INS}
37                 doins -r * || die "IDE installation failed!"
38
39                 # pick out those files which should be executable
40                 for EFIL in $(grep -RI '^#!' * | cut -d : -f 1 | grep -iv '\.txt$')
41                 do
42                         # and if there are any - install them
43                         exeinto "${INS}/$(dirname ${EFIL})"
44                         doexe "${EFIL}" || die
45                 done
46         fi
47 }