]> Pileus Git - ~andy/sunrise/blob - dev-cpp/libcwd/libcwd-0.99.47.ebuild
36ea614f2101372429797d36d544af759481ca8b
[~andy/sunrise] / dev-cpp / libcwd / libcwd-0.99.47.ebuild
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils
6
7 DESCRIPTION="A library to support C++ developers with debugging their applications"
8 HOMEPAGE="http://libcwd.sourceforge.net/"
9 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
10
11 LICENSE="QPL"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE="debug doc examples pch"
15
16 DEPEND="doc? ( app-doc/doxygen )"
17 RDEPEND=""
18
19 src_unpack() {
20         unpack ${A}
21         cd "${S}"
22
23         sed -i \
24                 -e 's/-O3//' \
25                 configure || die "sed failed"
26
27         epatch "${FILESDIR}"/gcc-4.3.patch ||die
28
29         # Clean-out possibly old docs
30         rm -f  documentation/doxygen.config
31         rm -rf documentation/html/*
32 }
33
34 src_compile() {
35         econf \
36                 $(use_enable pch) \
37                 $(use_enable debug) \
38                 || die "econf failed"
39         emake || die "emake failed"
40
41         if use doc; then
42                 cd documentation
43                 doxygen doxygen.config
44         fi
45 }
46
47 src_install() {
48         emake -j1 DESTDIR="${D}" install || die "emake install failed"
49
50         dodoc README* NEWS
51
52         if use doc; then
53                 dohtml -r documentation/reference-manual/*
54                 insinto /usr/share/doc/${PF}
55                 doins -r documentation/tutorial
56         fi
57
58         if use examples; then
59                 insinto /usr/share/doc/${PF}
60                 doins -r example-project
61         fi
62 }