]> Pileus Git - ~andy/sunrise/blob - dev-cpp/cppcms/cppcms-1.0.1-r1.ebuild
dev-cpp/cppcms: Revision bump for dev-cpp/cppcms
[~andy/sunrise] / dev-cpp / cppcms / cppcms-1.0.1-r1.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=4
6
7 PYTHON_DEPEND="2"
8
9 inherit cmake-utils multilib python
10
11 DESCRIPTION="A Free C++ Web Development Framework aimed for Rapid Web Application Development"
12 HOMEPAGE="http://cppcms.sourceforge.net/wikipp/en/page/main"
13 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
14
15 LICENSE="ALADDIN Boost-1.0 LGPL-3 MIT public-domain"
16 #This project has LGPL-3 license, but some parts of it are distributed under other mentioned licenses,
17 #for more information see THIRD_PARTY_SOFTWARE.TXT in docs directory
18 SLOT="0"
19 KEYWORDS="~amd64 ~x86"
20 IUSE="+cache doc examples +fcgi gcrypt +http icu +prefork_cache +scgi +tcpcache"
21
22 REQUIRED_USE="prefork_cache? ( cache )
23         tcpcache? ( cache )"
24
25 DEPEND="dev-libs/libpcre
26         sys-libs/zlib
27         gcrypt? ( dev-libs/libgcrypt )
28         !gcrypt? ( dev-libs/openssl:0 )
29         icu? ( dev-libs/icu )
30         !icu? ( virtual/libiconv )
31 "
32 RDEPEND="${DEPEND}"
33
34 src_prepare() {
35         python_convert_shebangs 2 bin/cppcms_tmpl_cc
36 }
37
38 src_configure() {
39         local mycmakeargs="-DDISABLE_STATIC=OFF
40                 -DDISABLE_SHARED=OFF
41                 -DDISABLE_GZIP=OFF
42                 -DDISABLE_ICU_LOCALE=OFF
43                 $(cmake-utils_use_disable !icu ICONV)
44                 $(cmake-utils_use_disable gcrypt GCRYPT)
45                 $(cmake-utils_use_disable !gcrypt OPENSSL)
46                 $(cmake-utils_use_disable fcgi FCGI)
47                 $(cmake-utils_use_disable scgi SCGI)
48                 $(cmake-utils_use_disable http HTTP)
49                 $(cmake-utils_use_disable prefork_cache PREFORK_CACHE)
50                 $(cmake-utils_use_disable tcpcache TCPCACHE)
51                 $(cmake-utils_use_disable cache CACHE)
52                 -DLIBDIR=$(get_libdir)"
53         cmake-utils_src_configure
54 }
55
56 src_install() {
57         cmake-utils_src_install
58         dodoc THIRD_PARTY_SOFTWARE.TXT
59         if use doc; then
60                 dohtml -r doc/doxygen/html/*
61         fi
62         if use examples; then
63                 rm examples/{autogenerated.doxy,examples.doxy,examples.txt,format.sh} || die
64                 insinto /usr/share/doc/${PF}
65                 doins -r examples
66         fi
67 }