]> Pileus Git - ~andy/sunrise/blob - dev-cpp/ETL/ETL-0.04.08.ebuild
dev-cpp/ETL: Fix invalid version and invalid SRC_URI
[~andy/sunrise] / dev-cpp / ETL / ETL-0.04.08.ebuild
1 # Copyright 1999-2007 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 WANT_AUTOCONF="latest"
6 WANT_AUTOMAKE="1.6"
7 inherit autotools
8
9 DESCRIPTION="VoriaETL is a multiplatform class and template library designed to complement and supplement the C++ STL."
10 HOMEPAGE="http://www.synfig.com/"
11 SRC_URI="http://www.bridgetone.com/voria/files/${P}.tar.gz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="doc"
17 DEPEND="doc? ( app-doc/doxygen )"
18
19
20 src_compile() {
21         ./bootstrap || die 'Bootstrap failed.'
22         econf || die 'Configure failed.'
23         emake || die 'Make failed.'
24         if use doc; then 
25                 emake docs || die "make docs failed."
26         fi
27 }
28
29 src_install() {
30         emake DESTDIR="${D}" install || die 'Install failed!'
31         if use doc; then
32                 dohtml doc/html/*
33         fi
34 }