]> Pileus Git - ~andy/sunrise/blob - app-vim/clewn/clewn-1.10.ebuild
e681b5bbfda86bc8b1474164d1e17af7cadf5d97
[~andy/sunrise] / app-vim / clewn / clewn-1.10.ebuild
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6
7 inherit vim-doc
8
9 DESCRIPTION="A small utility which allows debugging from within vim"
10 HOMEPAGE="http://clewn.sourceforge.net/"
11 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="debug"
17
18 DEPEND=">=app-editors/gvim-7.0[netbeans]
19         sys-libs/readline"
20 RDEPEND="${DEPEND}
21         sys-devel/gdb"
22
23 src_configure() {
24         vimdir=/usr/share/vim/vimfiles econf $(use_enable debug)
25 }
26
27 src_install() {
28         emake DESTDIR="${D}" install || die "emake install failed"
29         dodoc ChangeLog README || die "dodoc failed"
30 }
31
32 pkg_postinst() {
33         update_vim_helptags
34 }