]> Pileus Git - ~andy/sunrise/blob - app-text/peg-markdown/peg-markdown-0.4.12.ebuild
dev-lang/dmd: Bump to 2.062. Keeping some older versions in case of regressions.
[~andy/sunrise] / app-text / peg-markdown / peg-markdown-0.4.12.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=4
6
7 inherit eutils toolchain-funcs vcs-snapshot
8
9 DESCRIPTION="An implementation of John Gruber's markdown in C"
10 HOMEPAGE="https://github.com/jgm/peg-markdown"
11 SRC_URI="https://github.com/jgm/${PN}/tarball/${PV} -> ${P}.tar.gz"
12
13 LICENSE="|| ( GPL-2 MIT )"
14 SLOT="0"
15 KEYWORDS="~x86"
16 IUSE=""
17
18 DEPEND="dev-util/peg"
19 RDEPEND="${DEPEND}"
20
21 src_prepare() {
22         epatch \
23                 "${FILESDIR}/${P}-Makefile.patch" \
24                 "${FILESDIR}/${P}-declare.patch"
25 }
26
27 src_compile() {
28         emake CC="$(tc-getCC)"
29 }
30
31 src_install() {
32         exeinto usr/bin
33         doexe ${PN}
34         dolib.so lib${PN}.so.${PV}
35         dosym lib${PN}.so.${PV} usr/lib/lib${PN}.so
36         dohtml README.html
37         insinto usr/include
38         doins markdown_lib.h
39 }