]> Pileus Git - ~andy/sunrise/blob - app-text/orayta/orayta-0.03_p2.ebuild
app-dicts/orayta-books: Bump
[~andy/sunrise] / app-text / orayta / orayta-0.03_p2.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="3"
6
7 inherit qt4-r2
8
9 MY_PV=${PV/_p/ubuntu}
10 DESCRIPTION="Reader for Orayta Jewish Book Collection"
11 HOMEPAGE="http://orayta.googlecode.com/"
12 SRC_URI="http://launchpad.net/~moshe-wagner/+archive/orayta/+files/${PN}_${MY_PV}.tar.gz"
13
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="~amd64"
17 IUSE=""
18
19 DEPEND=">=dev-qt/qtgui-4.5:4
20         >=dev-qt/qtxmlpatterns-4.5:4
21         >=kde-base/kdelibs-4
22         >=dev-qt/qtwebkit-4.5:4"
23 RDEPEND="${DEPEND}
24         app-dicts/orayta-books"
25
26 S="${WORKDIR}/svn"
27
28 src_prepare() {
29         #Unhide project file (for some reason hidden in tarball)
30         mv hide.tmp Orayta.pro || die 'Project File missing'
31
32         sed -i 's|/usr/local/bin|/usr/bin|' Orayta.pro
33
34         qt4-r2_src_prepare
35 }