]> Pileus Git - ~andy/sunrise/blob - app-text/discount/discount-2.1.5a.ebuild
b571262299b608e5d08e5b3836351f822d2a7684
[~andy/sunrise] / app-text / discount / discount-2.1.5a.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=4
6
7 DESCRIPTION="An implementation of John Gruber's Markdown text to html language written in C"
8 HOMEPAGE="http://www.pell.portland.or.us/~orc/Code/discount/"
9 SRC_URI="http://www.pell.portland.or.us/~orc/Code/${PN}/${P}.tar.bz2"
10
11 LICENSE="DLPARSONS"
12 SLOT="0"
13 KEYWORDS="~x86"
14 IUSE="minimal"
15
16 src_prepare() {
17         # for QA, we remove the Makefiles usage of install -s
18         sed -e '/INSTALL_PROGRAM/s#-s ##' -i configure.inc \
19         || die "sed can't fix stripping of files"
20 }
21
22 src_configure() {
23         local myconf
24         use minimal || myconf="--enable-all-features"
25
26         ./configure.sh "${myconf}" \
27         --prefix=/usr \
28         --mandir=/usr/share/man \
29         || die
30 }
31
32 src_install() {
33         local myinstall
34         use minimal && myinstall="install" || myinstall="install.everything"
35         emake DESTDIR="${D}" ${myinstall}
36 }