]> Pileus Git - ~andy/sunrise/blob - app-office/unoconv/unoconv-0.3-r3.ebuild
8947e0136fff1dc9a58f69a5a4b3d06fcf4e2ad0
[~andy/sunrise] / app-office / unoconv / unoconv-0.3-r3.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6
7 inherit eutils
8
9 DESCRIPTION="Convert between any document format supported by OpenOffice"
10 HOMEPAGE="http://dag.wieers.com/home-made/unoconv/"
11 SRC_URI="http://dag.wieers.com/home-made/${PN}/${P}.tar.bz2"
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE=""
16
17 DEPEND="app-text/asciidoc
18         dev-python/setuptools"
19 RDEPEND="|| ( app-office/openoffice app-office/openoffice-bin )"
20
21 src_prepare() {
22         epatch "${FILESDIR}/${P}-openoffice-3.2.patch" \
23                 "${FILESDIR}/${P}-longer-timeout.patch"
24 }
25
26 src_install() {
27         emake install DESTDIR="${D}" bindir='$(prefix)/share/unoconv' || die
28         newbin "${FILESDIR}"/unoconv-wrapper unoconv || die
29 }