]> Pileus Git - ~andy/sunrise/blob - app-office/radicale/radicale-0.6.2.ebuild
14ee0cb372f93361b52fb5922596fe5efff6a70a
[~andy/sunrise] / app-office / radicale / radicale-0.6.2.ebuild
1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=2
6 PYTHON_DEPEND="*:2.6"
7 SUPPORT_PYTHON_ABIS=1
8
9 inherit distutils
10
11 MY_PN="Radicale"
12 MY_P="${MY_PN}-${PV}"
13
14 DESCRIPTION="A simple CalDAV calendar server"
15 HOMEPAGE="http://www.radicale.org/"
16 SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
17
18 LICENSE="GPL-3"
19 SLOT="0"
20 KEYWORDS="~x86 ~amd64"
21 IUSE="fastcgi ldap ssl"
22
23 # the '>=' goes ok, as radicale supports _all_ other python version
24 # this includes all 3.* versions
25 RDEPEND="ssl? ( >=dev-lang/python-2.6.6[ssl] )
26                 ldap? ( dev-python/python-ldap )
27                 fastcgi? ( dev-python/flup )"
28
29 S=${WORKDIR}/${MY_P}
30
31 src_install() {
32         # delete the useless .rst, so that it is not installed
33         rm README.rst
34
35         distutils_src_install
36
37         # init file
38         newinitd "${FILESDIR}"/radicale.init.d radicale || die
39
40         # config file
41         insinto /etc/${PN}
42         doins config logging || die
43
44         # fcgi and wsgi files
45         insinto /usr/share/${PN}
46         doins radicale.wsgi
47         use fastcgi && doins radicale.fcgi
48 }
49
50 pkg_postinst() {
51         einfo "Radicale now supports WSGI."
52         einfo "A sample wsgi-script has been put into ${ROOT}usr/share/${PN}."
53         use fastcgi && einfo "You will also find there an example fcgi-script."
54 }