]> Pileus Git - ~andy/sunrise/blob - app-office/ganttproject-bin/ganttproject-bin-2.0.2.ebuild
e3d29056bea35f76a4028d22932d9bb674ed59d7
[~andy/sunrise] / app-office / ganttproject-bin / ganttproject-bin-2.0.2.ebuild
1 # Copyright 1999-2007 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils
6
7 KEYWORDS="~x86"
8
9 MY_P=${PN/-bin}-${PV}
10
11 DESCRIPTION="A tool for creating a project schedule by means of Gantt chart and resource load chart."
12 HOMEPAGE="http://ganttproject.sourceforge.net/"
13 SRC_URI="mirror://sourceforge/ganttproject/${MY_P}.zip"
14 LICENSE="GPL-2"
15 SLOT="0"
16 IUSE=""
17
18 DEPEND="app-arch/unzip
19                 virtual/jdk"
20 RDEPEND="virtual/jre"
21
22 S="${WORKDIR}/${MY_P}"
23
24 src_install() {
25         cd "${S}"
26         insinto /usr/share/${PN}
27         doins -r eclipsito.jar plugins/
28
29         newbin "${FILESDIR}/${PV%.*}-${PN}" ${PN}
30
31         insinto /usr/share/${PN}/examples
32         doins *.gan
33
34         doicon "${S}/plugins/net.sourceforge.ganttproject_${PV%.*}.0/data/resources/icons/ganttproject.png"
35         make_desktop_entry ${PN} "GanttProject" ${PN/-bin} "Java;Office;ProjectManagement"
36 }