]> Pileus Git - ~andy/sunrise/blob - app-misc/rbutil/rbutil-1.2.8.ebuild
104aa46e04d73f561894f6429a35c26a63c6654b
[~andy/sunrise] / app-misc / rbutil / rbutil-1.2.8.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=2
6 LANGS="cs de fi fr he it ja nl pl pt pt_BR ru tr zh_CN zh_TW"
7
8 inherit eutils qt4-r2
9
10 MY_P=${PN}_${PV}
11
12 DESCRIPTION="Rockbox opensource firmware manager for mp3 players"
13 HOMEPAGE="http://www.rockbox.org/twiki/bin/view/Main/RockboxUtility"
14 SRC_URI="http://download.rockbox.org/${PN}/source/${MY_P}-src.tar.bz2"
15
16 LICENSE="GPL-2"
17 SLOT="0"
18 KEYWORDS="~amd64 ~x86"
19 IUSE="debug"
20
21 RDEPEND="media-libs/speex
22         dev-qt/qtcore:4
23         dev-qt/qtgui:4
24         virtual/libusb:0"
25 DEPEND="${RDEPEND}"
26
27 S=${WORKDIR}/${MY_P}/${PN}/${PN}qt
28
29 src_prepare() {
30         epatch "${FILESDIR}/${PV}"-fix-parallel-make.patch
31 }
32
33 src_configure() {
34         # generate binary translations
35         lrelease ${PN}qt.pro || die
36
37         # noccache is required in order to call the correct compiler
38         eqmake4 CONFIG+=noccache
39 }
40
41 src_install() {
42         newbin RockboxUtility ${PN} || die
43         newicon icons/rockbox-5.png ${PN}.png || die
44         make_desktop_entry ${PN} "Rockbox Utility"
45 }