]> Pileus Git - ~andy/sunrise/blob - app-misc/rbutil/rbutil-1.2.14.ebuild
app-misc/rbutil: Bump, fix qt deps, EAPI bump
[~andy/sunrise] / app-misc / rbutil / rbutil-1.2.14.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="5"
6 LANGS="cs de fi fr he it ja nl pl pt pt_BR ru tr zh_CN zh_TW"
7
8 inherit eutils qt4-r2
9
10 DESCRIPTION="Rockbox opensource firmware manager for mp3 players"
11 HOMEPAGE="http://www.rockbox.org/twiki/bin/view/Main/RockboxUtility"
12 SRC_URI="http://download.rockbox.org/${PN}/source/RockboxUtility-v${PV}-src.tar.bz2"
13
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17 IUSE="debug"
18
19 RDEPEND="media-libs/speex
20         dev-qt/qtcore:4
21         dev-qt/qtgui:4
22         virtual/libusb:0"
23 DEPEND="${RDEPEND}"
24
25 S="${WORKDIR}/RockboxUtility-v${PV}/${PN}/${PN}qt"
26
27 src_configure() {
28         # generate binary translations
29         lrelease ${PN}qt.pro || die
30
31         # noccache is required in order to call the correct compiler
32         eqmake4 CONFIG+=noccache
33 }
34
35 src_install() {
36         newbin RockboxUtility ${PN} || die
37         # FIXME: is this the right icon?
38         newicon icons/rockbox.ico ${PN}.png || die
39         make_desktop_entry ${PN} "Rockbox Utility"
40 }