]> Pileus Git - ~andy/sunrise/blob - app-misc/qbrew/qbrew-0.4.1.ebuild
1f1369ade8779b76d890303b3e3b2aa1232adaa5
[~andy/sunrise] / app-misc / qbrew / qbrew-0.4.1.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6 inherit qt4-r2 multilib
7
8 DESCRIPTION="Homebrewer's recipe calculator"
9 HOMEPAGE="http://www.usermode.org/code.html"
10 SRC_URI="http://www.usermode.org/code/${P}.tar.gz"
11
12 LICENSE="BSD-2"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE=""
16
17 DEPEND="dev-qt/qtgui:4"
18 RDEPEND="${DEPEND}"
19
20 src_configure() {
21         export BINDIR="/usr/bin" DATADIR="/usr/share/${PN}" DOCDIR="/usr/share/doc/${P}"
22         ./configure --qtdir="/usr/$(get_libdir)/qt4" || die "configure failed"
23         echo "QT += xml" >> qbrew.pro
24         eqmake4
25 }
26
27 src_install() {
28         dobin qbrew || die "bin install failed"
29         insinto /usr/share/${PN}
30         doins data/* pics/splash.png || die "install failed"
31         dohtml -r docs/* || die "documentation install failed"
32         dodoc AUTHORS ChangeLog README TODO || die "documentation install failed"
33 }