]> Pileus Git - ~andy/sunrise/blob - app-misc/qbrew/qbrew-0.3.9.ebuild
173e29229ff6ced1fa96f4d3509f31be939c8fb5
[~andy/sunrise] / app-misc / qbrew / qbrew-0.3.9.ebuild
1 # Copyright 1999-2007 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="1"
6 inherit qt4
7
8 DESCRIPTION="Homebrewer's recipe calculator"
9 HOMEPAGE="http://www.usermode.org/code.html"
10 SRC_URI="http://www.usermode.org/code/${P}.tar.gz"
11
12 LICENSE="as-is"
13 SLOT="0"
14 KEYWORDS="~x86"
15 IUSE=""
16
17 DEPEND=">=x11-libs/qt-4.1:4"
18 RDEPEND="${DEPEND}"
19
20 src_compile() {
21         # configure script is broken/bad
22         export BINDIR="/usr/bin" DATADIR="/usr/share/${PN}" DOCDIR="/usr/share/doc/${P}"
23         eqmake4
24         emake || die "emake failed"
25 }
26
27 src_install() {
28         dobin qbrew
29         insinto /usr/share/${PN}
30         doins data/* pics/splash.png
31         dohtml -r docs/*
32         dodoc AUTHORS ChangeLog README TODO
33 }