]> Pileus Git - ~andy/sunrise/blob - app-misc/pcmanfm/pcmanfm-0.3.2.2.ebuild
b3700afd71e54af9f94b7b5118e34fce396e0d44
[~andy/sunrise] / app-misc / pcmanfm / pcmanfm-0.3.2.2.ebuild
1 # Copyright 1999-2006 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 MY_P=${P/_beta/-beta}
6
7 DESCRIPTION="Extremely fast and lightweight tabbed file manager"
8 HOMEPAGE="http://pcmanfm.sourceforge.net/"
9 SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE="fam hal"
15
16 RDEPEND="fam? ( virtual/fam )
17         x11-libs/cairo
18         >=x11-libs/gtk+-2.8
19         x11-misc/shared-mime-info
20         hal? ( >=sys-apps/hal-0.5.0 )"
21 DEPEND="${RDEPEND}
22         dev-util/pkgconfig"
23
24 S=${WORKDIR}/${MY_P}
25
26 pkg_setup() {
27         if ! use fam ; then
28                 ewarn "You have disabled fam, experimental inotify support"
29                 ewarn "will be used instead. If you have problems, then"
30                 ewarn "recompile this package with USE=\"fam\""
31         fi
32 }
33
34 src_compile() {
35         econf \
36                 $(use_enable hal) \
37                 $(use_enable !fam inotify) \
38                 || die "econf failed"
39         emake || die "emake failed"
40 }
41
42 src_install() {
43         emake DESTDIR="${D}" install || die "emake install failed"
44         dodoc AUTHORS TODO
45 }
46
47 pkg_postinst() {
48         if use fam && has_version app-admin/fam ; then
49                 elog "You are using fam as your file alteration monitor,"
50                 elog "so you must have famd started before running pcmanfm."
51                 elog
52                 elog "To add famd to the default runlevel and start it, run:"
53                 elog
54                 elog "# rc-update add famd default"
55                 elog "# /etc/init.d/famd start"
56                 elog
57                 elog "It is recommended you use gamin instead of fam."
58         fi
59 }