]> Pileus Git - ~andy/sunrise/blob - app-misc/japanese-vocabulary/japanese-vocabulary-0.6-r1.ebuild
app-misc/bsc: Fix qt deps, EAPI bump
[~andy/sunrise] / app-misc / japanese-vocabulary / japanese-vocabulary-0.6-r1.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="5"
6 inherit eutils qt4-r2 toolchain-funcs
7
8 KEYWORDS="~amd64 ~x86"
9
10 MY_PN=JapaneseVocabulary
11
12 DESCRIPTION="A simple vocabulary program for studying Japanese."
13 HOMEPAGE="http://code.google.com/p/japanese-vocabulary/"
14 SRC_URI="http://${PN}.googlecode.com/files/${MY_PN}-${PV}-src.tar.gz"
15 LICENSE="GPL-2"
16 SLOT="0"
17 IUSE=""
18
19 DEPEND="dev-qt/qtgui:4
20         dev-qt/qtsql:4[sqlite]"
21 RDEPEND="${DEPEND}"
22
23 S=${WORKDIR}/${PN}
24
25 src_install() {
26         dobin ${MY_PN}
27         keepdir /usr/share/${PN}
28 }
29
30 pkg_postinst() {
31         elog "To fetch an up-to-date vocabulary file, run:"
32         elog "  emerge --config =${CATEGORY}/${PF}"
33 }
34
35 pkg_config() {
36         cd "${ROOT}usr/share/${PN}"
37         wget "http://japanese-vocabulary.googlecode.com/files/jlpt.vocab"
38         einfo "The vocabulary database is in:"
39         einfo "  /usr/share/${PN}"
40 }
41
42 pkg_postrm() {
43         # do not leave orphaned cruft behind
44         if ! has_version ${CATEGORY}/${PN} ; then
45                 [[ -d ${ROOT}/usr/share/${PN} ]] && rm -rf "${ROOT}"/usr/share/${PN}
46         fi
47 }