]> Pileus Git - ~andy/sunrise/blob - app-misc/gvrng/gvrng-4.4.ebuild
e8d0d5756c5139c291d03193046846c71529eaaf
[~andy/sunrise] / app-misc / gvrng / gvrng-4.4.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="5"
6
7 PYTHON_COMPAT=( python2_7 )
8 inherit eutils python-r1
9
10 DESCRIPTION="The Guido van Robot Programming Language"
11 HOMEPAGE="http://gvr.sourceforge.net"
12 SRC_URI="mirror://sourceforge/gvr/GvRng_${PV}.tgz"
13
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="~x86"
17 IUSE="doc"
18
19 DEPEND="${PYTHON_DEPS}
20         dev-python/pygtk:2
21         dev-python/pygobject:2
22         dev-python/pygtksourceview:2"
23
24 RDEPEND="${DEPEND}"
25
26 S="${WORKDIR}/GvRng_${PV}"
27
28 src_prepare() {
29         epatch "${FILESDIR}"/01_gui_gtk_path.patch
30 }
31
32 src_install() {
33         insinto /usr/share/${PN}
34         doins -r *.py gvrngrc gui-gtk bitmaps gvr_progs locale po
35         dodoc Changelog docs/Summary-en.txt
36         if use doc; then
37                 dohtml -r docs/tutorial.html docs/lessons
38         fi
39         fperms 755 /usr/share/${PN}/gvrng.py
40         dodir /usr/bin
41         dosym /usr/share/${PN}/gvrng.py /usr/bin/gvrng
42         domenu "${FILESDIR}"/gvrng.desktop
43         doman docs/gvrng.1.gz
44 }
45
46 pkg_postinst() {
47         einfo "The tutorial and the lessons can be found in "
48         einfo "/usr/share/doc/${PF}."
49         einfo "If you can not find them, emerge the package with USE=doc."
50 }