]> Pileus Git - ~andy/sunrise/blob - app-misc/gvrng/gvrng-4.4.ebuild
98138ece2bb1c7e61ec9f512e09dffad5d2dbb34
[~andy/sunrise] / app-misc / gvrng / gvrng-4.4.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6
7 inherit eutils
8
9 DESCRIPTION="The Guido van Robot Programming Language"
10 HOMEPAGE="http://gvr.sourceforge.net"
11 SRC_URI="mirror://sourceforge/gvr/GvRng_${PV}.tgz"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~x86"
16 IUSE="doc"
17
18 DEPEND="dev-lang/python
19         >=dev-python/pygtk-2.0.0
20         dev-python/pygobject:2
21         >=dev-python/pygtksourceview-2.0.0"
22
23 RDEPEND="${DEPEND}"
24
25 S=${WORKDIR}/GvRng_${PV}
26
27 src_prepare() {
28         epatch "${FILESDIR}"/01_gui_gtk_path.patch
29 }
30
31 src_install() {
32         insinto /usr/share/${PN}
33         doins -r *.py gvrngrc gui-gtk bitmaps gvr_progs locale po || die "Failed to install files"
34         dodoc Changelog docs/Summary-en.txt || die "Failed to install docs"
35         if use doc; then
36                 dohtml -r docs/tutorial.html docs/lessons || die "Failed to install tutorial and lessons"
37         fi
38         fperms 755 /usr/share/${PN}/gvrng.py || die "Failed to set permissions on gvrng.py"
39         dodir /usr/bin || die "Failed to create /usr/bin"
40         dosym /usr/share/${PN}/gvrng.py /usr/bin/gvrng || die "Failed to create symlink"
41         domenu "${FILESDIR}"/gvrng.desktop || die "Failed to copy desktop file"
42         doman docs/gvrng.1.gz  || die "Failed to install man page"
43 }
44
45 pkg_postinst() {
46         einfo "The tutorial and the lessons can be found in "
47         einfo "/usr/share/doc/${PF}."
48         einfo "If you can not find them, emerge the package with USE=doc."
49 }