]> Pileus Git - ~andy/sunrise/blob - app-misc/fslint/fslint-2.24.ebuild
3fc4d82bff0c0e546a4bb63257a6e182433807f8
[~andy/sunrise] / app-misc / fslint / fslint-2.24.ebuild
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils python multilib
6
7 DESCRIPTION="A utility to find various forms of lint on a filesystem"
8 HOMEPAGE="http://www.pixelbeat.org/fslint/"
9 SRC_URI="http://www.pixelbeat.org/${PN}/${P}.tar.gz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE="nls"
15
16 DEPEND="nls? ( sys-devel/gettext )"
17 RDEPEND=">=dev-python/pygtk-2.0"
18
19 src_install() {
20         dodir /usr/share/${PN}
21         cp -R ${PN}/ "${D}"/usr/share/${PN}
22
23         insinto /usr/share/${PN}
24         doins ${PN}{.glade,.gladep,_icon.png} || die "doins failed"
25
26         exeinto /usr/bin
27         doexe ${PN}-gui || die "doexe failed"
28
29         python_version
30         local pydir="/usr/$(get_libdir)/python${PYVER}/site-packages/${PN}"
31         dodir ${pydir}
32         echo "liblocation = '/usr/share/${PN}/'" > "${D}"/${pydir}/__init__.py
33
34         doicon ${PN}_icon.png
35         domenu ${PN}.desktop
36
37         dodoc doc/*
38         doman man/*
39
40         if use nls ; then
41                 cd po
42                 emake DESTDIR="${D}"/usr DATADIR=share install || die "locales install failed"
43         fi
44 }
45
46 pkg_postinst() {
47         python_mod_optimize "${ROOT}usr/$(get_libdir)/python${PYVER}/site-packages/${PN}"
48 }
49
50 pkg_postrm() {
51         python_version
52         python_mod_cleanup "${ROOT}usr/$(get_libdir)/python${PYVER}/site-packages/${PN}"
53 }