]> Pileus Git - ~andy/sunrise/blob - app-misc/bsc/bsc-4.1.0.ebuild
app-misc/autokey-gtk: Add ~amd64 keyword, EAPI bump
[~andy/sunrise] / app-misc / bsc / bsc-4.1.0.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=2
6
7 inherit eutils qt4-r2
8
9 DESCRIPTION="Qt-based file manager"
10 HOMEPAGE="http://www.beesoft.org/index.php?id=bsc"
11 SRC_URI="http://www.beesoft.org/download/${PN}_${PV}_src.tar.bz2"
12
13 LICENSE="GPL-2"
14 SLOT="0"
15 IUSE=""
16 KEYWORDS="~amd64 ~x86"
17
18 DEPEND="dev-qt/qtgui:4
19         x11-libs/libX11
20         x11-libs/libXext"
21 RDEPEND="${DEPEND}"
22
23 S=${WORKDIR}/${PN}
24
25 src_prepare() {
26         default
27
28         # Drop forced CXXFLAGS
29         sed -i -e "/^QMAKE_CXXFLAGS_RELEASE/d" ${PN}.pro || die
30         # Set up the help file path
31         sed -i \
32                 -e "s;QApplication::applicationDirPath();\"/usr/share/doc/${PF}/html\";" \
33                 QBtHelp.cpp || die
34 }
35
36 src_install() {
37         dobin ${PN} || die
38         dohtml help.en.html || die
39
40         newicon BeesoftCommander.png ${PN}.png || die
41         make_desktop_entry ${PN} BSCommander ${PN} "FileManager;Utility;Qt"
42 }