]> Pileus Git - ~andy/sunrise/blob - app-misc/bbgallery/bbgallery-1.2.0-r2.ebuild
4a4e2d33dbec447da26275612ef498ec0f0ed14b
[~andy/sunrise] / app-misc / bbgallery / bbgallery-1.2.0-r2.ebuild
1 # Copyright 1999-2007 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils
6
7 DESCRIPTION="Webpage image gallery creation perl script"
8 HOMEPAGE="http://bbgallery.sourceforge.net/"
9 SRC_URI="mirror://sourceforge/bbgallery/${P}.tar.bz2"
10
11 SLOT="0"
12 LICENSE="GPL-2"
13 KEYWORDS="~x86"
14 IUSE=""
15
16 RDEPEND="dev-lang/perl
17         media-gfx/imagemagick
18         dev-perl/URI
19         dev-perl/libwww-perl
20         dev-perl/HTML-Template
21         dev-perl/HTML-Parser"
22
23 DEPEND=""
24
25 src_unpack() {
26         unpack ${A}
27         cd "${S}"
28         epatch "${FILESDIR}"/bbgallery-1.2.0.patch
29 }
30
31 src_install() {
32         INSPATH="/usr/share/bbgallery"
33         dobin bbgallery || die "dobin failed"
34         newbin Contrib/JPG2jpg.pl JPG2jpg || die "newbin failed"
35         exeinto "${INSPATH}"
36         doexe gimp_scale.pl || die "doexe failed"
37         insinto "${INSPATH}"
38         doins -r template/
39         dosym "${INSPATH}"/template/monochrome "${INSPATH}"/template/default \
40                 || die "dosym failed"
41         dodoc CHANGELOG CREDITS README
42         dohtml doc/*.html
43 }