]> Pileus Git - ~andy/sunrise/blob - app-misc/bashstyle-ng/bashstyle-ng-7.10.ebuild
d606d560b5a44d949f52ddc35e3831abe85109e6
[~andy/sunrise] / app-misc / bashstyle-ng / bashstyle-ng-7.10.ebuild
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6
7 inherit eutils gnome2
8
9 DESCRIPTION="A graphical tool for changing the Bashs behaviour"
10 HOMEPAGE="http://www.nanolx.org/"
11 SRC_URI="http://download.tuxfamily.org/bashstyleng/${P}.tar.bz2"
12
13 LICENSE="GPL-3"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="acpi dmi doc pci pdf usb"
17
18 DEPEND="x11-libs/vte[python]
19         sys-devel/gettext
20         acpi? ( sys-power/acpi )
21         dmi? ( sys-apps/dmidecode )
22         pci? ( sys-apps/pciutils )
23         pdf? ( app-text/ghostscript-gpl )
24         usb? ( sys-apps/usbutils )"
25 RDEPEND="${DEPEND}"
26
27 DOCS="AUTHORS ChangeLog README TODO"
28
29 src_prepare() {
30         epatch "${FILESDIR}/${P}-gconf-update.patch"
31 }
32
33 src_install() {
34         if use doc; then
35                 dohtml documentation/* || die "documentation installation failed"
36         fi
37         gnome2_src_install
38 }