]> Pileus Git - ~andy/sunrise/blob - app-misc/autokey-gtk/autokey-gtk-0.61.3.ebuild
app-misc/autokey-gtk: Adding ~amd64 keyword
[~andy/sunrise] / app-misc / autokey-gtk / autokey-gtk-0.61.3.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=3
6
7 inherit distutils
8
9 DESCRIPTION="A programm for automating tasks in Linux"
10 HOMEPAGE="http://autokey.sourceforge.net/"
11 SRC_URI="http://autokey.googlecode.com/files/${PN}_${PV}.tar.gz"
12
13 LICENSE="GPL-3"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE=""
17
18 DEPEND=">=dev-python/python-xlib-0.14
19         dev-python/notify-python
20         dev-python/pygtk"
21
22 RDEPEND="${DEPEND}"
23
24 S="${WORKDIR}/build"
25
26 src_install(){
27         distutils_src_install
28         newinitd "${S}"/debian/autokey-gtk.init autokey || die
29 }
30
31 pkg_postinst () {
32         einfo "You should now run /etc/init.d/dbus reload"
33         einfo " You may now start the ${PN} deamon with /etc/init.d/autokey start."
34         einfo " If you want to start the deamon every time Gentoo starts,"
35         einfo " you should run rc-update add autokey default"
36 }