]> Pileus Git - ~andy/sunrise/blob - app-misc/2gis/2gis-3.0.9.1.ebuild
390b2662d7603abd826249fc600e10ef54c11ad0
[~andy/sunrise] / app-misc / 2gis / 2gis-3.0.9.1.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6
7 inherit eutils
8
9 DESCRIPTION="Proprietary freeware multimedia map of several Russian and Ukrainian towns"
10 HOMEPAGE="http://2gis.ru"
11 SRC_URI="http://download.2gis.ru/arhives/2GISShell-${PV}.orig.zip"
12
13 LICENSE="2Gis-ru"
14 SLOT="0"
15 KEYWORDS="~x86 ~amd64"
16 IUSE="+data"
17
18 DEPEND="app-arch/unzip"
19 RDEPEND="app-emulation/wine
20         data? ( app-misc/2gis-data )"
21
22 pkg_setup() {
23         check_license "${FILESDIR%/files}"/../../licenses/${LICENSE}
24 }
25
26 src_install() {
27         insinto /opt/${PN}
28         doins -r 2gis/3.0/* || die
29
30         make_wrapper 2gis "wine grym.exe -nomta" /opt/${PN}
31         make_desktop_entry 2gis 2Gis || die
32 }