]> Pileus Git - ~andy/sunrise/blob - app-laptop/toshset/toshset-1.75.ebuild
baa32806fbd752f5adef59acaad415e4e3b71a1c
[~andy/sunrise] / app-laptop / toshset / toshset-1.75.ebuild
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI="2"
6
7 DESCRIPTION="Utility to modify HCI/SCI controls on Toshiba Laptops"
8 HOMEPAGE="http://www.schwieters.org/toshset/"
9 SRC_URI="http://dev.gentooexperimental.org/~hwoarang/distfiles/${P}.tgz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE="debug"
15
16 DEPEND=""
17 RDEPEND=""
18
19 src_prepare() {
20         sed -i 's/CFLAGS = -march=i486 \(-Wall @OS_CFLAGS@ @DEBUGFLAGS@\)/CFLAGS := \1 ${CFLAGS}/' "${S}/Makefile.in" || die "sed failed"
21 }
22
23 src_configure(){
24         econf $(use_enable debug)
25 }
26
27 src_install() {
28         emake DESTDIR="${D}" install || die "emake install failed"
29         dodoc README || die
30 }