]> Pileus Git - ~andy/sunrise/blob - app-laptop/acerhdf/acerhdf-0.5.25.ebuild
sunrise/ net-nntp/nzbperl/Manifest: Update copyright line to satisfy repoman
[~andy/sunrise] / app-laptop / acerhdf / acerhdf-0.5.25.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit linux-mod
6
7 MY_PN=${PN}_kmod
8 MY_P=${MY_PN}-${PV}
9
10 DESCRIPTION="A kernelmodule which monitors the temperature of the aspire one netbook"
11 HOMEPAGE="http://piie.net/index.php?section=acerhdf"
12 SRC_URI="http://piie.net/files/${MY_P}.tar.gz"
13
14 LICENSE="GPL-2"
15
16 SLOT="0"
17 KEYWORDS="~amd64 ~x86"
18 IUSE=""
19
20 S=${WORKDIR}/${MY_PN}
21
22 BUILD_TARGETS="default"
23 MODULE_NAMES="${PN}(:${S}:${S})"
24 MODULESD_ACERHDF_DOCS="README.txt"
25 BUILD_PARAMS="KDIR=${KERNEL_DIR}"
26 CONFIG_CHECK="!ACERHDF ~THERMAL ~THERMAL_HWMON ~ACPI"
27
28 pkg_setup() {
29         linux-mod_pkg_setup
30         if kernel_is lt 2 6 30; then
31                 ewarn "This version of ${PN} needs at least kernel version 2.6.30 selected"
32                 ewarn "Please set the /usr/src/linux symlink to the right version"
33                 die "This version of ${PN} needs at least kernel version 2.6.30 selected"
34         fi
35 }
36
37 pkg_postinst() {
38         linux-mod_pkg_postinst
39         einfo "The module now starts with kernel mode off"
40         einfo "Add options acerhdf kernelmode=1 to your"
41         einfo "/etc/modprobe.d/acerhdf.conf to enable it at loadtime"
42 }