]> Pileus Git - ~andy/sunrise/blob - app-laptop/acerhdf/acerhdf-0.5.17.ebuild
app-laptop/acerhdf: version bump
[~andy/sunrise] / app-laptop / acerhdf / acerhdf-0.5.17.ebuild
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit linux-mod
6
7 MY_PN=${PN}_kmod
8 MY_P=${MY_PN}-${PV}
9
10 DESCRIPTION="A kernelmodule which monitors the temperature of the aspire one netbook"
11 HOMEPAGE="http://piie.net/index.php?section=acerhdf"
12 SRC_URI="http://piie.net/files/${MY_P}.tar.gz"
13
14 LICENSE="GPL-2"
15
16 SLOT="0"
17 KEYWORDS="~amd64 ~x86"
18 IUSE=""
19
20 RDEPEND=">=virtual/linux-sources-2.6.30"
21 DEPEND="${RDEPEND}"
22
23 S=${WORKDIR}/${MY_PN}
24
25 BUILD_TARGETS="default"
26 MODULE_NAMES="${PN}(:${S}:${S})"
27 MODULESD_ACERHDF_DOCS="README.txt"
28 BUILD_PARAMS="KDIR=${KERNEL_DIR}"
29
30 pkg_setup() {
31         linux-mod_pkg_setup
32         if kernel_is lt 2 6 30; then
33                 ewarn "This version of ${PN} needs at least kernel version 2.6.30 selected"
34                 ewarn "Please set the /usr/src/linux symlink to the right version"
35                 die "This version of ${PN} needs at least kernel version 2.6.30 selected"
36         fi
37 }
38
39 pkg_postinst() {
40         linux-mod_pkg_postinst
41         einfo "The module now starts with kernel mode off"
42         einfo "Add options acerhdf kernelmode=1 to your"
43         einfo "/etc/modprobe.d/acerhdf.conf to enable it at loadtime"
44 }