]> Pileus Git - ~andy/sunrise/blob - app-emulation/dynagen/dynagen-0.11.0.ebuild
sunrise/ net-nntp/nzbperl/Manifest: Update copyright line to satisfy repoman
[~andy/sunrise] / app-emulation / dynagen / dynagen-0.11.0.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit multilib python
6
7 DESCRIPTION="Text-based frontend to Dynamips Cisco router emulator."
8 HOMEPAGE="http://www.dynagen.org/"
9 SRC_URI="mirror://sourceforge/dyna-gen/${P}.tar.gz"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64"
14 IUSE=""
15
16 DEPEND=""
17 RDEPEND="app-emulation/dynamips"
18
19 src_install() {
20         insinto $(python_get_sitedir)
21         doins *.py || die "python files install failed"
22
23         dobin ${PN} || die "failed install of /usr/bin/dynagen"
24
25         insinto /etc
26         doins ${PN}.ini || die "config file install failed"
27
28         insinto /usr/share/${PN}
29         doins configspec || die "failed configspec install"
30
31         dodoc README.txt
32
33         insinto /usr/share/doc/${P}
34         doins -r sample_labs
35         dohtml -r docs/*
36 }
37
38 pkg_postinst() {
39         python_version
40         python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages
41 }
42
43 pkg_postrm() {
44         python_mod_cleanup
45 }