]> Pileus Git - ~andy/sunrise/blob - app-editors/yzis/yzis-1.0_alpha1.ebuild
app-dicts/words-bin: Add ~amd64 keyword, EAPI bump
[~andy/sunrise] / app-editors / yzis / yzis-1.0_alpha1.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=2
6
7 inherit cmake-utils
8
9 MY_P=${P/_/-}
10
11 DESCRIPTION="Vi-like editor inspired by vim"
12 HOMEPAGE="http://www.yzis.org/"
13 SRC_URI="http://labs.freehackers.org/attachments/download/45/${MY_P}.tar.bz2"
14
15 LICENSE="GPL-2 LGPL-2.1"
16 SLOT="0"
17 KEYWORDS="~amd64 ~x86"
18 IUSE=""
19
20 DEPEND="
21         app-doc/doxygen
22         >=dev-lang/lua-5.1
23         sys-libs/ncurses
24         dev-qt/qtgui:4
25         dev-qt/qttest:4
26         "
27 RDEPEND="${DEPEND}"
28
29 DOCS="ChangeLog README"
30
31 S="${WORKDIR}/${MY_P}"
32
33 src_configure() {
34         mycmakeargs="${mycmakeargs}  -DENABLE_TESTS=OFF \
35                 -DENABLE_LIBYZISRUNNER=OFF \
36                 -DDCMAKE_BUILD_TYPE=Release "
37         cmake-utils_src_configure
38 }