]> Pileus Git - ~andy/sunrise/blob - app-editors/tea/tea-14.2.4.ebuild
tea/tea-14.2.4.ebuild: Added ~x86 keyword thanks to armin76
[~andy/sunrise] / app-editors / tea / tea-14.2.4.ebuild
1 # Copyright 1999-2006 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils
6
7 DESCRIPTION="Small GTK+ text editor"
8 HOMEPAGE="http://tea-editor.sourceforge.net"
9 SRC_URI="mirror://sourceforge/tea-editor/${P}.tar.bz2"
10
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE="ipv6 gnome"
15
16 RDEPEND=">=x11-libs/gtk+-2.2
17         >=app-text/aspell-0.50.5
18         gnome? ( >=x11-libs/gtksourceview-1.6.1 )"
19 DEPEND="${RDEPEND}
20         dev-util/pkgconfig"
21
22 src_compile() {
23         econf \
24         $(use_enable ipv6 ) \
25         $(use_enable !gnome legacy ) \
26         || die "Configure failed!"
27
28         emake || die "Make failed!"
29 }
30
31 src_install() {
32         emake DESTDIR="${D}" install || die "Make Install failed!"
33
34         doicon ${FILESDIR}/tea.png
35 #       domenu ${FILESDIR}/tea.desktop
36         make_desktop_entry tea Tea tea Office
37 }