]> Pileus Git - ~andy/sunrise/blob - app-dicts/words-bin/words-bin-1.97.ebuild
app-dicts/words-bin: fixing mirror
[~andy/sunrise] / app-dicts / words-bin / words-bin-1.97.ebuild
1 # Copyright 1999-2006 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils
6
7 MY_P="${P/-bin}"
8
9 DESCRIPTION="Latin-English dictionary."
10 HOMEPAGE="http://users.erols.com/whitaker/words.htm"
11 SRC_URI="http://atrey.karlin.mff.cuni.cz/~sanda/mirror/${MY_P}-linux.tar.gz"
12 #SRC_URI="ftp://petrus.thomasaquinas.edu/pub/linux/words/${MY_P}-linux.tar.gz"
13 #Reported problems with downloading
14
15 SLOT="0"
16 LICENSE="words"
17 KEYWORDS="~x86"
18
19 IUSE=""
20 DEPEND=""
21 RDEPEND=""
22
23 S=${WORKDIR}/${MY_P}
24
25 src_unpack(){
26         unpack ${A}
27         cd "${S}"
28         epatch "${FILESDIR}"/words_dir.patch
29 }
30
31 src_install() {
32         insinto /opt/${MY_P}
33         dodir /usr/bin
34         dodoc wordsdoc*
35         rm wordsdoc*
36         doins *
37         dosym "${D}"/opt/${MY_P}/latin /usr/bin/latin
38         fperms 755 /opt/${MY_P}/{latin,words}
39 }
40
41 pkg_postinst() {
42         elog "Dictionary is launched through 'latin' command"
43 }